首页 » 建站技术 » WordPress » 浏览内容

几行代码让你的WordPress兼容更多浏览器


2010-12-27 00:54:57 4,725 0 发表评论 字体: 作者:C.K.
标签: javascriptWordPress代码

体验版 88 元,个人版 128 元,多用户版 288元个人版160元升级到多用户版。

我们在修改主题的时候,经常遇到主题与浏览器的不兼容问题,一般我们会采取一些方法来解决这一问题,下面这个就可以解决Wordpress主题与浏览器的不兼容问题:
在你的主题文件夹里找到functions.php文件,之后添加以下代码:

  add_filter('body_class','browser_body_class');
  •  function browser_body_class($classes) {
  •  global $is_lynx, $is_gecko, $is_IE, $is_opera, $is_NS4, $is_safari, $is_chrome, $is_iphone;
  •  if($is_lynx) $classes[] ='lynx';
  •  elseif($is_gecko) $classes[] = 'gecko';
  •  elseif($is_opera) $classes[] = 'opera';
  •  elseif($is_NS4) $classes[] = 'ns4';
  •  elseif($is_safari) $classes[] = 'safari';
  •  elseif($is_chrome) $classes[] = 'chrome';
  •  elseif($is_IE) $classes[] = 'ie';
  •  else $classes[] = 'unknown';
  •  if($is_iphone) $classes[] = 'iphone';
  •  return $classes;
  •  }
  •  ?>
  • 这样,你的主题代码就可以兼容相应的浏览器了。

    网站统计 Statistics

    • 创建时间: 2005年1月3日 距今5067 天
    • 日志总数: 2461
    • 评论总数: 630
    • 标签总数: 654
    • 链接总数: 273
    • 最后更新: 2018-8-31 17:57:04
    • 您是本站第 14170020 位访客

    广告区 Guǎng Gào