首页 » VPS 知识 » 浏览内容

成都易悠网络科技云主机,安装LUM,使用ShopEx网上商店系统


2012-01-23 21:21:32 3,685 0 发表评论 字体: 作者:C.K.
标签: phpShopExVPS云主机

体验版 88 元,个人版 128 元,多用户版 288元个人版160元升级到多用户版。

由于 ShopEx 程序使用了 Zend 加密,只能支持 PHP 5.2.17,如果要想使用LUM最新版,所以只能将PHP版本在安装前改掉。

一、最小化安装CentOS是没有工具的

安装工具:

yum install wget

yum install setuptool

yum install gcc gcc-c++ autoconf vixie-cron

yum install gcc gcc-c++ autoconf crontabs

yum install make

make是gcc的编译器,VPS买来必定要安装,同时,如果你是最小化安装centos系统,当你需要安装某个工具时也会用到,比如我要安装haparm 9.39,就会提示无法make.
解决问题的方法:
安装:
yum -y install gcc automake autoconf libtool make
安装g++:
yum -y install gcc gcc-c++

二、VPS修复系统默认美洲时间更改为:中国上海

date -R

mv /etc/localtime /etc/localtime.bak

cp /usr/share/zoneinfo/Asia/Shanghai /etc/localtime

hwclock

三、安装 sendmail

yum install sendmail

/etc/init.d/sendmail restart

四、安装LUM

wget http://down.zijidelu.org/zijidelu_install.tar.gz

tar zxvf zijidelu_install.tar.gz

cd zijidelu_install

wget http://down4.zijidelu.org/projects/zijidelu-lunamp/files/LuNamp2.2/LuNamp_last.tar.gz

不要问为什么要用这个地址,因为用 wget http://down.zijidelu.org/LuNamp_last.tar.gz 下载有时是2011年7月份的。

tar zxvf LuNamp_last.tar.gz

修改LuNamp/code/php/php.sh文件,将本号改掉(例如将5.3.9改成5.2.17)

wget http://down.zijidelu.org/LuManager_last.tar.gz

tar zxvf LuManager_last.tar.gz

./i.sh 执行zijidelu_install目录下的i.sh

不要用RPM安装,选 N ;不要升级系统,选 N ;其它选 Y 。

该内容仅限于会员浏览,请 登录注册
Q: centos 64位安装完lum后8888打开空白或者出错,怎么办?

A: 解决办法是 编辑 /usr/local/php_LuManager/lib/php.ini 找到最后把eaccelerator 这段整个去掉 或者注释掉就行。

该内容仅限于会员浏览,请 登录注册

/home/lum_safe_files/config.php

/usr/local/LuManager/Conf/config.php

后台管理 ——帐户&安全——-密码与安全———保护密码

如果已经设置密码,显示 为“密码 保护密码已存在,如要修改,请先删除/home/lum_safe_files/safe_passwords/1520.key文件 ”

    网站统计 Statistics

    • 创建时间: 2005年1月3日 距今4949 天
    • 日志总数: 2461
    • 评论总数: 630
    • 标签总数: 654
    • 链接总数: 273
    • 最后更新: 2017-7-1 18:16:33
    • 您是本站第 13725627 位访客

    广告区 Guǎng Gào