关闭 WordPress 3.01 修订版本、自动保存功能

林继 WordPress 2,526 共写了410个字 (2010-08-20 17:46:22) 没有评论 打印 扫描二维码 百度已收录

由于WordPress升级成3.01后,原来的不用插件禁用wordpress自动保存功能已不能使用,于是去网上搜罗了一个能在WordPress 3.01版本上使用的关闭 修订版本、自动保存功能的文章,现在转载过来,经本人测试有效,方法如下:

1.在 wp-config.php 中添加以下代码:

  1. define('WP_POST_REVISIONS', false);
  2. define('AUTOSAVE_INTERVAL', false);

2.找到wp-admin\post-new.php wp-admin\post.php文件,把下面代码注释掉:

  1. wp_enqueue_script('autosave');

改为:

  1. //wp_enqueue_script('autosave');

3.在wp-admin\includes\post.php文件的:

  1. if ( $create_in_db ) {

代码上面添加:

  1. $create_in_db = false;

这样就可以彻底解决自动保存和自动修订问题。

历史上的今天

8月
20

如果觉得我的文章对您有用,请随意赞赏。您的支持将鼓励我继续创作!

发表评论

电子邮件地址不会被公开。 必填项已用*标注

< >