成都易悠网络科技云主机,安装LUM,使用ShopEx网上商店系统

林继 VPS 知识 5,026 共写了1506个字 (2012-01-23 21:21:32) 没有评论 打印 扫描二维码 百度未收录

由于 ShopEx 程序使用了 Zend 加密,只能支持 PHP 5.2.17,如果要想使用LUM最新版,所以只能将PHP版本在安装前改掉。

一、最小化安装CentOS是没有工具的

安装工具:

yum install wget

yum install setuptool

yum install gcc gcc-c++ autoconf vixie-cron

yum install gcc gcc-c++ autoconf crontabs

yum install make

make是gcc的编译器,VPS买来必定要安装,同时,如果你是最小化安装centos系统,当你需要安装某个工具时也会用到,比如我要安装haparm 9.39,就会提示无法make.
解决问题的方法:
安装:
yum -y install gcc automake autoconf libtool make
安装g++:
yum -y install gcc gcc-c++

二、VPS修复系统默认美洲时间更改为:中国上海

date -R

mv /etc/localtime /etc/localtime.bak

cp /usr/share/zoneinfo/Asia/Shanghai /etc/localtime

hwclock

三、安装 sendmail

yum install sendmail

/etc/init.d/sendmail restart

四、安装LUM

wget http://down.zijidelu.org/zijidelu_install.tar.gz

tar zxvf zijidelu_install.tar.gz

cd zijidelu_install

wget http://down4.zijidelu.org/projects/zijidelu-lunamp/files/LuNamp2.2/LuNamp_last.tar.gz

不要问为什么要用这个地址,因为用 wget http://down.zijidelu.org/LuNamp_last.tar.gz 下载有时是2011年7月份的。

tar zxvf LuNamp_last.tar.gz

修改LuNamp/code/php/php.sh文件,将本号改掉(例如将5.3.9改成5.2.17)

wget http://down.zijidelu.org/LuManager_last.tar.gz

tar zxvf LuManager_last.tar.gz

./i.sh 执行zijidelu_install目录下的i.sh

不要用RPM安装,选 N ;不要升级系统,选 N ;其它选 Y 。[level l=0,10]

修改shopex的config文件
define(‘SECACHE_SIZE’,’64M’)

  1. [Zend] 
  2. ;;;;;;;zend5.2.X
  3. zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer
  4. zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS
  5. zend_optimizer.version=3x
  6. zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so 
  7. zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so 
  8.  
  9. ;;;;;;;zend5.3.X
  10. ;zend_extension=/usr/local/Zend/ZendGuardLoader.so
  11. ;zend_loader.obfuscation_level_support=3
  12. ;zend_loader.disable_licensing=0
  13.  
  14. [eaccelerator]
  15. ;extension="/usr/local/php/lib/php/extensions/no-debug-non-zts-20060613/eaccelerator.so"
  16. ;extension_dir="/usr/local/php/lib/php/extensions/no-debug-non-zts-20060613/"
  17. ;extension = "eaccelerator.so"
  18. ;eaccelerator.shm_size="8"
  19. ;eaccelerator.cache_dir="/tmp"
  20. ;eaccelerator.enable="1"
  21. ;eaccelerator.optimizer="1" 
  22. ;eaccelerator.check_mtime="1" 
  23. ;eaccelerator.debug="0" 
  24. ;eaccelerator.filter="" 
  25. ;eaccelerator.shm_max="0" 
  26. ;eaccelerator.shm_ttl="0" 
  27. ;eaccelerator.shm_prune_period="0"      
  28. ;eaccelerator.shm_only="0"
  29. ;eaccelerator.compress="1" 
  30. ;eaccelerator.compress_level="9" 
  31.  
  32. [memcache]
  33. ;extension_dir="/usr/local/php/lib/php/extensions/no-debug-non-zts-20090626/"
  34. ;extension = "memcache.so"
  35. ;output_buffering = On

[/level]Q: centos 64位安装完lum后8888打开空白或者出错,怎么办?

A: 解决办法是 编辑 /usr/local/php_LuManager/lib/php.ini 找到最后把eaccelerator 这段整个去掉 或者注释掉就行。

[level l=0,10]安装前修改版本号 /root/zijidelu_install/LuNamp/code/config.sh

[/level]

/home/lum_safe_files/config.php

/usr/local/LuManager/Conf/config.php

后台管理 ——帐户&安全——-密码与安全———保护密码

如果已经设置密码,显示 为“密码 保护密码已存在,如要修改,请先删除/home/lum_safe_files/safe_passwords/1520.key文件 ”

如果觉得我的文章对您有用,请随意赞赏。您的支持将鼓励我继续创作!

发表评论

电子邮件地址不会被公开。 必填项已用*标注

< >